Tabnine Logo
net.java.truevfs.kernel.spec
Code IndexAdd Tabnine to your IDE (free)

How to use net.java.truevfs.kernel.spec

Best Java code snippets using net.java.truevfs.kernel.spec (Showing top 20 results out of 315)

origin: net.java.truevfs/truevfs-kernel-spec

@Override
public final FsModel newModel(
    final FsManager context,
    final FsMountPoint mountPoint,
    final FsModel parent) {
  assert null == parent
        ? null == mountPoint.getParent()
        : parent.getMountPoint().equals(mountPoint.getParent());
  return driver(mountPoint).newModel(context, mountPoint, parent);
}
origin: net.java.truevfs/truevfs-kernel-spec

@Override
public FsModel newModel(
    FsDriver context,
    FsMountPoint mountPoint,
    FsModel parent) {
  assert null == parent
        ? null == mountPoint.getParent()
        : parent.getMountPoint().equals(mountPoint.getParent());
  return manager.newModel(context, mountPoint, parent);
}
origin: net.java.truevfs/truevfs-comp-jmx

  @Override
  public void sync() throws FsSyncWarningException, FsSyncException {
    new FsSync()
        .filter(FsControllerFilter.forPrefix(model.getMountPoint()))
        .run();
  }
}
origin: net.java.truevfs/truevfs-kernel-spec

@Override
public final FsController newController(
    final FsManager context,
    final FsModel model,
    final @CheckForNull FsController parent)
throws ServiceConfigurationError {
  assert null == parent
        ? null == model.getParent()
        : parent.getModel().equals(model.getParent());
  return driver(model.getMountPoint()).newController(context, model, parent);
}
origin: net.java.truevfs/truevfs-kernel-spec

  @Override
  public int compare(FsController o1, FsController o2) {
    return o2.getModel().getMountPoint().toHierarchicalUri().compareTo(
        o1.getModel().getMountPoint().toHierarchicalUri());
  }
}
origin: net.java.truevfs/truevfs-comp-jmx

@Override
public String getMountPointOfParent() {
  final FsModel parent = model.getParent();
  return null != parent ? parent.getMountPoint().toString() : null;
}
origin: net.java.truevfs/truevfs-comp-jmx

@Override
public String getMountPoint() {
  return model.getMountPoint().toString();
}
origin: net.java.truevfs/truevfs-kernel-spec

@Override
public final FsNode node(BitField<FsAccessOption> options, FsNodeName name) throws IOException {
  return controller.node(map(options), name);
}
origin: net.java.truevfs/truevfs-comp-jmx

  @Override
  public boolean accept(FsController controller) {
    return controller.getModel().isMounted();
  }
}
origin: net.java.truevfs/truevfs-kernel-spec

  @Override
  public final void unlink(BitField<FsAccessOption> options, FsNodeName name) throws IOException {
    controller.unlink(map(options), name);
  }
}
origin: net.java.truevfs/truevfs-kernel-spec

@Override
public final OutputSocket<? extends Entry> output(BitField<FsAccessOption> options, FsNodeName name, Entry template) {
  return controller.output(map(options), name, template);
}
origin: net.java.truevfs/truevfs-kernel-spec

@Override
public final void checkAccess(BitField<FsAccessOption> options, FsNodeName name, BitField<Access> types) throws IOException {
  controller.checkAccess(map(options), name, types);
}
origin: net.java.truevfs/truevfs-kernel-spec

@Override
public final boolean setTime(BitField<FsAccessOption> options, FsNodeName name, Map<Access, Long> times) throws IOException {
  return controller.setTime(map(options), name, times);
}
origin: net.java.truevfs/truevfs-kernel-spec

@Override
public final void setReadOnly(BitField<FsAccessOption> options, FsNodeName name)
throws IOException {
  controller.setReadOnly(map(options), name);
}
origin: net.java.truevfs/truevfs-kernel-spec

@Override
public final InputSocket<? extends Entry> input(BitField<FsAccessOption> options, FsNodeName name) {
  return controller.input(map(options), name);
}
origin: net.java.truevfs/truevfs-kernel-spec

@Override
public void checkAccess(
    BitField<FsAccessOption> options,
    FsNodeName name,
    BitField<Access> types)
throws IOException {
  controller.checkAccess(options, name, types);
}
origin: net.java.truevfs/truevfs-kernel-spec

@Override
public void unlink(
    BitField<FsAccessOption> options,
    FsNodeName name)
throws IOException {
  controller.unlink(options, name);
}
origin: net.java.truevfs/truevfs-kernel-spec

/** Returns a controller filter for the given prefix mount point. */
public static FsControllerFilter forPrefix(FsMountPoint prefix) {
  return new FsControllerFilter(FsModelFilter.forPrefix(prefix));
}
origin: net.java.truevfs/truevfs-kernel-spec

/**
 * Returns the {@code mounted} property of the
 * {@linkplain #getModel() file system model}.
 *
 * @return the {@code mounted} property of the
 *         {@linkplain #getModel() file system model}.
 */
public final boolean isMounted() {
  return model.isMounted();
}
origin: net.java.truevfs/truevfs-kernel-spec

@Override
public final boolean setTime(BitField<FsAccessOption> options, FsNodeName name, BitField<Access> types, long value) throws IOException {
  return controller.setTime(map(options), name, types, value);
}
net.java.truevfs.kernel.spec

Most used classes

  • FsModel
    Defines common properties of any file system. Implementations should be safe for multi-threaded acce
  • FsScheme
    Addresses a file system scheme. This is simply a java.net.URI scheme according to the syntax constra
  • FsMountPoint
    Addresses a file system mount point.SPECIFICATION A mount point adds the following syntax constrain
  • FsNodeName
    Addresses a file system node relative to its FsMountPoint.SPECIFICATION An node name adds the follo
  • FsNodePath
    Addresses a file system node. The purpose of a file system path is to parse a URI and decompose it i
  • FsControllerFilter,
  • FsManager,
  • FsSync,
  • FsCovariantNode,
  • FsDriver,
  • FsNode,
  • FsOutputSocketSink,
  • FsReadOnlyFileSystemException,
  • MultiplexingOutputService,
  • FsManagerLocator,
  • IoBufferPoolLocator,
  • FsAbstractCompositeDriver,
  • FsAbstractController,
  • FsAbstractModel
Tabnine Logo
  • Products

    Search for Java codeSearch for JavaScript code
  • IDE Plugins

    IntelliJ IDEAWebStormVisual StudioAndroid StudioEclipseVisual Studio CodePyCharmSublime TextPhpStormVimGoLandRubyMineEmacsJupyter NotebookJupyter LabRiderDataGripAppCode
  • Company

    About UsContact UsCareers
  • Resources

    FAQBlogTabnine AcademyTerms of usePrivacy policyJava Code IndexJavascript Code Index
Get Tabnine for your IDE now